Xcodeで特定iPhoneでビルド&実行ができなかった話

iOS開発
スポンサーリンク

先日XcodeであるiPhoneで実行しようとするとビルドされないことがありました。
その解決方法を個人的な備忘録として残しておきたいと思います。

iPhoneを変えたばかり

これまで古いiPhone6などでXcodeを実行して動作を確認していました。
そして最近利用しているiPhone8で確認したところビルドが失敗してしまうことがありました。

 

あれ、同じ環境なのにどうして?

と思ったので下記のようにdeviceの状況をみることにしました。
「Window→Devices and Simulators」から開くことができます。

 

するとエラーが出ていることが発覚しました。

 

エラーの内容

ウィンドウをみるとこのようなエラーが。。。

The current device configuration is unsupported. This iPhone 8 (Model A1863, A1905, A1906, A1907) is running iOS 13.6 (17G68), which is not supported by Xcode 11.4.

 

文字通り、私が利用していた「スマホのバージョンが新しくて古いXcodeから実行できないよ~」ということでした。

Xcodeのバージョンを上げる必要があったということですね。

 

なので素直にAppStoreからXcodeを更新すれば解決されるようです。

‎Xcode
‎Xcode includes everything developers need to create great applications for Mac, iPhone, iPad, Apple TV, and Apple Watch. Xcode provides developers a unified wo...

ちなみに私のケースではMacBookAirのドライブ容量が足りなくてダウンロードできなかったため、直接ダウンロードすると若干サイズを抑えることができるのでそれで事なきを得ました・・・汗

 

最後に

いかがでしたでしょうか。

今回はシンプルでしたが同じような問題にぶつかった方の参考になれば幸いです。
ではここまでお読みいただきありがとうございました。

 

コメント

スポンサーリンク
タイトルとURLをコピーしました